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SPICE （Simulation Program with Integrated Circuit Emphasis）語言是由

UC Berkley 發展的的一種類比電路模擬程式語言，允許使用者建立各類電路模型

並進行頻率響應分析（frequency response） 暫態響應分析（transcient response）

或是直流掃描 （DC sweep） 等等各類型的電路計算工作。近代電路設計動輒包含

數十個獨立的主被動電路元件，對於初學者，非電子科系主修的學生而言要手算分析

這類複雜的電路實非易事。附帶優秀 GUI 介面且具備完整資料庫的 SPICE 套裝程

式可以幫助使用在極短時間檢驗自行設計的電路是否能正常工作，配合接近真實的電

路模型，透過模擬可修正細部參數，節省繁瑣的計算，大幅提昇實作時成功機率。因

此，學習使用電路模擬軟體也是實驗室電子學不可或區的一環。

1 LTspice

市面上有許多 SPICE　套裝軟體，需付費的商業版本有 Orcad 的 Pspice 與

ADS 的 HSPICE。前者的優勢在於龐大且完整的資料庫，也整合了 PCB Layout

功能，　GUI　介面也易於使用，後者則是以高頻類比電路模擬見長。

免費且附加　GUI 介面的 SPICE 版本則有 Orcad 的 Pspice student ，德州儀

器的 TiNA 與 Linear Tech. 的 LTspice。Pspice student 為功能受限制的 pspice

（電路結點數量不能超過 64 個），雖然具備正式版的優秀 GUI 介面，礙於使用限

制只能模擬極簡單的電路。TiNA 的優勢在於電路繪製介面漂亮精緻，但缺點在於內

建元件庫不夠完整，過份美化的介面反而不易操作。LTspice 則具備簡潔易用的 GUI

與波型檢視介面，也有熱心的使用者額外建立了實用元件庫提供眾人使用。LTspice

也提供 Linear Tech. 生產之元件最詳細的資料庫，使許多電源電路設計的下游工程

師選用 LTspice 作為主要的電路模擬軟體。

2 安安安裝裝裝 LTspice

請從 http://ltspice.linear.com/software/ 找尋最新版的 LTspice 進行

安裝。然後你可以從 Yahoo group http://tech.groups.yahoo.com/group/

LTspice/或是 LT Wiki :http://ltwiki.org/index.php5?title=Components_

Library找到擴充元件庫的安裝檔 LtSpiceIV Plus 12 2009 以及 LTspicePlus 10 08

，裡面有一些寫好的 OP IC 與 74 系列邏輯電路元件可使用。或者你也可以從 FTP

server 的 [課程資料]->[電路模擬軟體] 中找到相關的安裝檔。

3 LTspice 基基基本本本操操操作作作

開啟 Spice 以後可以看到命令列，操作快捷列與下方的電路放置區。

若要放置主動元件如電源，放大器或者 BJT等等可以從 [Editor]->[c0mponent]或

使用快捷鍵 [F2] 調出元件選單。
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快捷鍵與功能列

下方為電路編輯處

[F3]  wire 劃線

[G] ground 接地

[R]  resistance 電阻元件

[C] capacitor 電容元件

[L] inductor 電感元件

[D]  diode 二極體元件

滑鼠滾輪可縮放畫面，空白鍵可動 縮放

[T] 放入文字

注意！電路必須放入接地元件才能模擬

[F7] 移動元件

[Del] 刪除元件

Figure 1: 基本操作與快捷鍵表

直接輸入名稱可進行搜尋

以 [ ] 標示者代表目錄，可點擊進入子目錄

Figure 2: 從元件庫中選取元件
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常用的元件有這些，大部分的元件都可以透過縮寫來搜尋元件庫中是否有相對應

的元件：

∙ voltage ，可加入 DC，AC 與 Pulse 電壓源。

∙ current，類似 source ，只不過形成電流源。

∙ npn, pnp，理想的 BJT 元件，點擊該元件可調出進階選單呼叫實際的 BJT

元件，比方說 2N2222 與 2N3055

∙ nmos, pmos 理想的 MOS 元件，用法同 BJT。

∙ diode 與 BJT 元件相同，不從進階選單選取零件型號就代表理想的二極體模

型，換言之順向導通電壓為零，無崩潰電壓。

∙ zener 使用 zener 必須選取 type 標示為 zener 的二極體元件才行，否則在模

擬上就算圖案是 zener 二極體，結果還是當作理想二極體做計算。請依照需要

的崩潰電壓（Vbrkdn） 值選擇元件。

∙ e 這是壓控電壓源（voltage control voltage source），一般來說可以當成一

個有增益 （gain）的 stage 或是隔離驅動的 source，在電力電子電路或是隔離

雜訊的電路中常出現。g2 則是壓控電流源。

∙ xfmr, xfmr2 理想變壓器，請參考 Sec. 6.6.3。

∙ transformer2 真實變壓器，透過更改兩邊的電感值可以改變輸出輸入電壓

比，K 值則跟耗損有關。變壓比例與
√
L 有關，若要製造 1:3 的變壓比，電感

要設定成 1H:3H 。你可以利用 trans 搜尋到其他種類的變壓器（中央抽頭，

多線圈式等等）。請參考 Sec. 6.6.3。

∙ 1pole，opamp 理想放大器，你可以簡單修改開路增益 (Avol)，增益頻寬積

（GBW） 與輸入阻抗（Rin）等參數。

4 常常常用用用元元元件件件的的的參參參數數數設設設定定定

預設元件上通常有編號與屬性兩個文字標籤。前者為該元件進行模擬實的正式

編號，像是 v1, v2, R3, R3 等等，不可重複也不能空白。後者通常代表該元件的

特性，比方說電阻若將預設屬性標籤 R 修改為 12 meg 即代表電阻值 12 MΩ 。在

spice 語言中輸入數值不需要帶有物理單位，不同的數量級則可以使用不同的縮寫來

簡化輸入過程。

想要編輯元件進階屬性可以游標移至元件圖案上，出現手指圖案再點擊右鍵即可

呼叫設定選單。
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數量級 109 106 103 10−3 10−6 10−9 10−12 10−15

縮寫 G meg k m u n p f

Figure 3: 數量級縮寫對照表

4.1 voltage

使用 voltage可以製造 DC ，AC 與 PULSE 等等常用的電壓波形。不等週期

的脈衝電源則可利用進階選單中的 PWL 選項生成，EXP 則是指數衰減波形。製造

PULSE 波形時要注意 Tdelay、Ton、Trise 與 Tfall 的和一定要等於 Tperiod ，否

則計算會發生錯誤。這五樣與週期相關的參數可以只輸入四項，最後一項 spice 會自

動幫你計算。若想要模擬理想的脈衝源，使用者很可能會將 Tfall 與 Trise 設為 0，

但輸入 0 很容易造成電腦計算出無限大的情況（在暫態響應分析的時候特別容易出

現）。因此我們最好把這些你希望為零的值設為極小的數如 1u 或 1n （比電路中可

能出現的最小週期小十至百倍即可）。currrent 的設定大致上與 voltage 一樣。

4.2 被被被動動動元元元件件件 RCL

5 電電電路路路模模模擬擬擬

常用的電路分析有 DC 偏壓分析（DC bias）、頻率響應分析（frequency

response）、暫態響應分析(trancient response) 與 DC 掃描（DC sweep）。除了

上述幾種常用的模擬之外，LTspice 也提供了 noise 以及小訊號分析。要啟用模擬

功能，可以由 [Simulate]->[Run] 調出選單；另外在第一次設定參數之後，執行

Run 指令不會重新秀出參數設定表，只會依照之前設定的條件重新執行模擬，要變更

模擬參數請執行 [Simulate]->[Edit Simulation Cmd] 。

5.1 DC 分分分析析析

DC 分析將電路中所有電容視為斷路（open circuit），電感視為短路（short

circuit）。我們可以使用 simulate 選單中的 DC op pnt 來進行模擬。以下利用簡

單的電阻分壓電路來說明如何逕行直流偏壓分析。要注意的地方在於：模擬結果會以

netlist 的結果呈現（spice 語法定義的接腳，[View]->[SPICE Netlist] 可開啟

GUI 介面編輯完成之 netlist），為了方便起見最好事先預先觀察之節點加上 label

並給予適當之名稱。label 除了標示用途以外，也可以拿來簡化電路佈線，所有具有

相同名稱的 label 在模擬中都會接在同一點上。
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屬性標籤是否出現

在電路圖上的選項

設定 DC 值

設定 AC 小信號

可以加入串連電阻與並聯電容

來模擬真實電源，比方說電池

Figure 4: DC 電壓源

5.2 暫暫暫態態態響響響應應應

執行暫態響應（transient response）模擬可以讓我們觀察電路的時間波形。Fig. 13

利用簡單的二極體整流電路來說明如何設定模擬參數，Fig. 14，15 說明執行後查看

波形的方法。Fig. 16 說明如何加入 cursor。要修改繪圖參數可以只要在該波形視窗

下點選工具列 Plot Setting 即可:

∙ Add trace 加入新的波形，與游標點選電路圖功能相同。按住 ctrl 鍵可選取多

的波形同時顯示

∙ Delete Trace 游標出現剪刀圖案，點選波形視窗內玉去除的波形之標題即可

刪除

∙ Note & Annotations -> Label. Curs. Pos. 將當前 cursor 座標顯示

至波形圖上。

∙ Add plot plane 在同一個波形視窗內新增多個子圖
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可設定直流偏壓 

設定振幅，峰對峰值的一半

交流訊號的頻率

設定此電源要延遲多久才啟動

延遲相位，電路中包含多個交
流源時依使用者需求設定

Figure 5: AC 電壓源

Tdelay

Trise

Ton

Tperiod

Von

Vinitial

Figure 6: PULSE 電壓源

5.3 頻頻頻率率率響響響應應應

進行頻率響應分析必須在電路中置入一個 voltage 電壓源（類型可以是 none 或

sine），必須於進階選單中設定 Small signal analysis AC -> AC amplitude

（填入不為零的值即可）才能正確執行模擬。同樣地可藉由 add trace 觀察電路中不
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真實的電阻值有並非每個值都有
大致上以正負半個 Tolerance 分佈  

可修改誤差，最大功率

（常用有 0.5 W  1W  2W）

Figure 7: 電阻 resistance

電容等效電路

摘錄自 LTspice Help Manual

Figure 8: 電容 capacitor

同位置的頻率響應。

若要取得大範圍頻域的資訊（比方說 1 至 10 MHz ）模擬選單中的 type of

Sweep 通常選用 Octave 或是 Decade，取樣點數可設為 10 至 100 點，欲取得細部

資訊則使用 Linear 選項。模擬範圍或精度越大，計算的時間就越久，模擬參數的選

定必須依照使用者的要求隨時調整。

Fig. 17,18 為 LC 串聯電路頻率響應分析電路範例，先進行大範圍模擬看出大略

波形，再縮小範圍，提高計算精度找出細部特性。波形圖中實線代表振幅，虛線則代

表相位。
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電感等效電路

摘錄自 LTspice Help Manual

Figure 9: 電感 inductor

可重新編輯模擬參數

點擊

或者 [ Simulate] -> [Run]

Figure 10: 模擬設定選單

5.4 直直直流流流掃掃掃描描描

在模擬多端半導體元件電路特性的時候常常可以利用 DC sweep 這項模擬找出這

些非線性元件的工作點。Fig. 19 以二極體電路為例示範如何利用 DC sweep 找出電

路特性。

6 進進進階階階操操操作作作

6.1 計計計算算算波波波形形形的的的平平平均均均值值值與與與 rms 值值值

按住 Ctrl 鍵，將游標移至波形視窗波形標題上單擊左鍵，會跳出統計視窗顯示該

波形的平均值與 rms 值，積分範圍為視窗橫軸的可視範圍，積分起始點與終點位置資
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[F4] 加入 label

Figure 11: 簡單的分壓電路，使用 label 加入節點名稱方便之後讀取結果

括號內為結點名稱

正確算出 A 點分壓

I 開頭之數值為流經括號內編號元件之電流

Figure 12: 選擇 DC op pnt 可得直流偏壓結果

訊同樣出現在統計視窗中。

6.2 顯顯顯示示示某某某元元元件件件的的的跨跨跨壓壓壓

要測量某兩個節點間的電壓差很簡單，在電路圖上先在你視為正端的節點點擊左

鍵不放，你會發現游標探棒的顏色由紅轉為黑色，再移動游標至你視為負端的節點，

放開左鍵即可。此時波形視窗顯示的波形即正端節點的電壓值減去負端節點的電壓

值。如果要進行更複雜的運算就必須在 Add Trace 輸入節點的函數才行。
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設定振幅 5 V 1000 Hz 的正弦波電壓源

串連理想二極體與 100 歐姆之負載電阻

總模擬時間 5 ms

1 ms 後開始存取資料

最大模擬間距，通常

取比交流信號源信號

週期還小的值

Figure 13: 電路暫態響應分析設定

游標移至此處
出現探棒圖形

點擊左鍵即產生該點電壓波形

若該點有 label 則顯示 label 內容

Figure 14: 查看電壓時間波形

游標移至元件出現線圈標示，紅箭頭代表電流方向

點擊滑鼠左鍵

多個波形可同時顯示比較

Figure 15: 查看電流時間波形

6.3 改改改變變變波波波形形形圖圖圖的的的橫橫橫軸軸軸

參考 Fig. 20 二極體 I-V curve 的例子，執行 DC sweep 模擬後跳出波形圖視
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游標移至標題點擊後出現十字 cursor

調出 cursor 視窗
顯示該點數值

Figure 16: 利用 cursor 找出特定點之值

LC 串聯電路， L=10 uH, C=10 uF

先進行大範圍低精度的模擬看出大致波形

數據取樣為 10 point per Octave

起始頻率設為 1 Hz

終止頻率設為 100 kHz

Figure 17: 頻率響應模擬設定

窗，在座標橫軸上點擊左鍵可以呼叫 Horizontal Axis 選單，在 quantity plotted

一欄填入作為橫軸變量的節點函數即可。以此例來說，二極體的電壓若以節點變量

表示即 v(a)-v(b)（入若不事先在電路圖上設定 label 則對應到的節點名稱可能

是 v(n001)、v(n002) 等等較難識別的名稱，對於欲觀測的節點事先以 label 命

名可以方便後續的波形圖設定）。最後再以 Add Trace 加入二極體電流 I(D1) 作

為 y 軸即可繪出 I-v curve。y 軸變數當然也可以是節點的函數，原則上加減乘除

的運算都是允許的，座標軸的單位也會自動轉換。 Fig. 21即以二極體的等效電阻

(v(a)-v(b))/I(D1) 為縱軸，二極體電壓為橫軸繪製關係圖，並可由此估算出二極

體的導通電阻約為 100Ω 。

spice 支援的 expression （加減乘除以外還包含正餘弦函數、對數運算等等常用

13



取 Linear 模式，於 10 k 至 40 kHz 間取 10000 point 

若再縮小模擬間距會發現此處的極值會趨近於無限大

此即共振頻率

Figure 18: 細部掃描

置入任意數值 DC 電壓源

-二極體元件串連電阻直流電路特性

二極體電壓

二極體電流

填入變動 DC 源之名稱

設定電壓變動範圍與模擬精度
此例即計算 0, 0.1, 0.2 ...4.9, 5 V 的
直流分析結果並繪成 2 維圖表

Figure 19: DC sweep
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的函數）可以參考 http://bwrc.eecs.berkeley.edu/Classes/icbook/SPICE/

UserGuide/interactive_fr.html。

可輸入節點變數的函數

+ - *  / 等等運算皆可

輸入橫軸變量，可以是節點變數的函數

移至座標軸出現尺狀游標後點擊左鍵

模擬二極體 1 N4148 的 I-V curve

右鍵選單 -> Add Trace

Figure 20: I-V curve

6.4 輸輸輸出出出波波波形形形圖圖圖節節節點點點數數數據據據

在波形圖子視窗時，由工具列 [File]->[Export] 可以輸出節點數據，該數據以

txt 檔的形式儲存在 LTspice 的根目錄中，一般為 2 column 的形式（column 1 為

橫軸數據， column 2 為縱軸對應數據）。利用 Scilab 或 Excel 可以對這些數據做

進一步的處理。

6.5 改改改變變變波波波形形形圖圖圖背背背景景景色色色

波形圖背景預設為黑色，若想把波形圖轉貼至投影片或報告上則需要將背景改為

較清楚的白底色。參考Fig. 22 ，由工具列[Tools]->[Preference] 可以調整波形

圖的顏色參數。

6.6 SPICE 指指指令令令

LTspice 除了預設的 GUI 指令以外也支援 SPICE 指令的輸入，有一些實用的

功能需要使用者直接鍵入簡易的 SPICE 指令來改變模擬的參數。要輸入 SPICE 指

令可以點選 Text 圖示（button 上有 Au 字樣）或由 [Edit]->[Text] 呼叫修改視

15



輸入 (v(a)-v(b))/I(D1)

r局部放大

導通時等效電阻約 100 Ohm

Figure 21: 估計導通等效電阻

窗，將 How to netlist this text 欄位設為 SPICE directive 即可在下方鍵入指令，

完成後可將指令文字標籤上電路圖的任一處。

6.6.1 改改改變變變模模模擬擬擬溫溫溫度度度

輸入 .temp [temp] 即可，比方說 .temp 125 可以模擬工作溫度 125 ∘C 時元

件的電路特性。一般 LTspice 模擬時若不利用 .temp 設定溫度則溫度預設值為 27
∘C ，即 .temp 27。大家可以試試看在不同溫度下模擬二極體的 I-V curve 有何變

化（注意不要將溫度設定到接近絕對零度，否則模擬時間會大幅拉長也可能出現錯

誤）。

.temp 指令也可以模擬多個不同溫度下的模擬結果。Fig. 23 利用指令 .temp

-20 0 50 125 模擬 -20、0、50、125 ∘C 下二極體的 I-V curve。右鍵選單中的

Select Steps 可以選擇波形圖上要顯示的模擬曲線。

6.6.2 變變變動動動參參參數數數

除了溫度可以 sweep 同時繪出波形圖外，我們也可以利用 .STEP 指令來變

化被動元件的數值。Fig. 24以一個分壓電路為例，將其中一根電阻 R1 的值設

為變數 {rstep}，變數名稱必須用一組大括號標示。如果我們想同時畫出 R1

=1k、2k、3k、4k、5kΩ 時 R2 的分壓，我們可以使用指令 .STEP PARAM rstep
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background 設為

[Red,Green,Blue]=[255,255,255]

即為白色

axis 設為

[Red,Green,Blue]=[0,0,0]

即成較為清楚的白色

工具列  [ Tools]->[Color Preference]

Figure 22: 將波形圖改為白色背景

1k 5k 1k。你可以把 .STEP PARAM想成一個 for 迴圈，PARAM 代表指定一個型

態為參數的變數，rstep 是迴圈變數，迴圈變數由 1k 開始，5k 結束，迴圈變數增

量（increament）為 1k。如果只想模擬特定幾個數值，比方說 R1 為 1k、10k、與

1 meg 的情況，可以在加上 list 到指令中： .STEP PARAM rstep list 1k 10k

1meg 。

事實上 .TEMP -20 0 50 125 可以改寫為 .STEP PARAM temp list -20 0

50 125。要切換檢視STEP 製造出來的波形同樣可以從右鍵選單調出 Select Steps 視

窗即可。 除了被動元件外，.STEP 也可以用來變動電壓源，Fig. 25 就是利用.STEP

來變動基極電壓繪出 BJT 2N2222 的特性曲線。絕大多數的非線性元件的端點數都

在三個以上，這些元件的 I-V 特性根據觀察端點對的不同變化也較豐富，此例即使

用 DC sweep 分析來找出其他電路變數對於集極（collector）變化的曲線，再透過

.STEP PARAM vb 0.5 1.2 0.1同時繪出不同基極（base）電壓下集極電流對集極

電壓變化曲線。

6.6.3 製製製作作作變變變壓壓壓器器器元元元件件件

在 LTspice 中要製作變壓器要先在電路圖放置兩個電感器 L1 與 L2，再利用

SPICE 指令 K1 L1 L2 k=1 即完成輸入端為 L1、輸出端為 L2 且元件名稱 K1 之
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Step 選單

Figure 23: 1N4148 在不同溫度下的 I-V curve

變壓器元件，一般耦合參數 k 值設為 1 即代表無損耗之理想變壓器。Fig. 26 即變壓

比 1:2 之變壓器實例，變壓比與兩邊的電感值的根號成正比，若需要 1:3 的變壓比則

L1、L2 的電感值必須是 1:9。

6.6.4 頻頻頻譜譜譜分分分析析析

在 transient 分析下，我們可以將橫軸切換為頻率來觀察電路節點的頻譜，spice

會將資料點做 FFT （快速傅立葉轉換）繪製成圖供使用者分析諧波失真。在波形圖

上右鍵開啟選單，最下方 [view]->[FFT] 可輸出頻譜。 Fig. 27 即分析 2N2222 構

成之放大電路諧波失真的例子。原始信號 1 mV 1kHz 正弦波放大成 5 mV 的信號，

完美的放大器應該使 vout 也是完美的 1 kHz 弦波，但實際的情況 vout 會包含一

些高階諧波的成份。Fig. 27 圖上頻譜看似混亂，若將縱軸切換成 linear 表示可發現
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.STEP PARAM   rstep   1k   5k   1k 

指令保留字

需要 sweep 的變數名稱

起始值

終止值

increament

宣告變數

Figure 24: 分壓電路對元件參數 sweep 模擬

Figure 25: BJT 2N2222 sweep 模擬

K1  L1  L2  k=1

變壓器名稱，也可以是 K2、
K3 等等，必須是 K 開頭的名稱

輸入端的電感名稱（線圈）

輸出端的電感名稱（線圈）

耦合參數，當 k 等於 1 時
為理想變壓器

加入 SPICE 指令後電感圖案多出圓圈
即代表電感已耦合成變壓器

升壓比為   L1  :  L2

Figure 26: 製作變壓器

1kHz 分量遠大於其他諧波分量，此放大器在此頻率的表現接近理想。

若要提高 FFT 頻譜的精細度，可以增加 transient 分析的模擬時間（stop

time）或是降低maximum timpstep，只要模擬取樣的點數越多，FFT 的結果也會
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越準確。

理想輸出

放大失真，由非線性效應引入的高階諧波

波形圖右鍵選單 [ view]->[FFT]

Figure 27: 頻譜分析

6.7 輸輸輸入入入變變變動動動分分分析析析

對於電力電子電路而言，輸入變動分析乃衡量電力轉換電路抗干擾能力是否足夠

優秀的簡驗方式。Fig. 28 是一個由 zener 二極體（1N750，崩潰電壓約 4.7 V）構

成之穩壓電路，利用 zener 二極體的崩潰區，與之並聯之 4.7 kΩ 負載所感受到的

電壓在 V1 大於崩潰電壓時會保持在 4.7 V 附近。利用 PULSE 將 V1 模擬成平均

7 V，振幅 1 V 的方波餵進穩壓電路，我們發現負載電阻感應到漣波（ripple）振

幅約為 45 mV ，換句話說輸入端的變動傳遞到輸出端後變為原先的 45m/1=4.5%

，配合小訊號模型的分析可推斷 zener 二極體的逆向導通等效電阻約為串聯電阻的

4.5/(100-4.5)， 大約 100×4.7%=4.7 Ω 。 若以 -I(D1)*v(n002) 作為縱軸則可觀

察 zener 二極體消耗功率的變化。

20



輸入 7 V   1V 的 votage source

輸出端漣波振幅約為 (4.725-4.680)/2 = 45 mV

Figure 28: 穩壓電路輸入變動分析

7 音音音源源源分分分析析析

LTspice 的 transient 分析支援以 wav 檔作為電壓訊號源，也能將波形儲存成

wav 檔。我們可以利用這個特性來觀看聲音的頻譜，甚至可以用來模擬放大器電路的

失真與等化器效果。

7.1 以以以 wav 檔檔檔作作作為為為電電電壓壓壓源源源

先在電路圖上放置一個電壓元件，再將該電壓源的名稱改為 wavefile="D:∖sound1.wav"
chan=0 ，雙引號內為 wav 檔案的絕對路徑，此例即使用 D 槽下檔名為 sound1 檔

案作為電壓源， chan=0 代表左聲道，若使用 chan=1 則代表右聲道。Fig. 29 即使

用預錄約十秒的口哨聲音訊號，餵入 LTspice 並使用 transient 分析時間波形，以

FFT 觀察其頻譜。

7.2 以以以 wav 檔檔檔作作作為為為電電電壓壓壓源源源

使用 text 的 spice directive 模式鍵入以下指令：.wav "D:∖centralc.wave"
16 44100 soundout 。雙引號內為 wav 儲存路徑，將 soundout 節點的資料存到

centralc.wav之中，bit rate設為 16 bit，sampling frequency取為 44100。Fig. 30

中利用 SINE 電壓源製造一個 264 Hz 中央 C 的正弦波，transient 分析取十秒的數

據並利用 .wav 指令儲存至 centralc.wav。

7.3 放放放大大大電電電路路路失失失真真真模模模擬擬擬

利用先前章節頻譜分析介紹過的信號放大電路（2N2222），將電壓源改為一段

十餘秒的 wav 檔（test.wav），並使用 transient 分析將放大後的信號 vout 儲存至

testout.wav 中。 Fig. 31 為電路架構，Fig. 32 為輸入信號與輸出信號的頻譜。從

增益頻譜上我們可以看到高頻處的雜訊有被放大的現象，實際聆聽轉換後的 wav 檔
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SPICE 讀取 wav 指令 此段錄音之頻譜

錄音之時間波形

Figure 29: 在 LTspice 中引入 wav 檔

.wav  "d:\centralc.wav"   16   44100  soundout

將節點電壓資訊轉存到

此目錄，檔名如路徑名稱所示
欲儲存之節點

Bit Rate，除了16 以外可設定

1  至 32 任何一個數值，常用數值為

8，16，32 

Sampling Frequency，
常用的還有11025，22050

Figure 30: 在 LTspice 中輸出 wav 檔

（置於 FTP 上與本份文件同一個資料夾，test.wav 為原始音源，testout.wav 為轉

換後之檔案） 更能明顯聽出失真與爆音。
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Figure 31: 以 wav 聲音信號模擬放大電路失真

gain 頻譜 （ Vout/Vin）藍線為 Vout 頻譜 ，綠線為 Vin 頻譜

Figure 32: 輸入、輸出與增益（gain）頻譜

8 實實實戰戰戰演演演練練練

excercise 8.1：：： 電電電阻阻阻測測測量量量

參考 Fig. 33 ，請問如下圖以呈正立方體排列的電阻球在 A、B 兩點間的等效電

阻為何(R=1 Ω)？若 A、B 間的電位差設為 1 V，則 B 點與 C 點的電位分別為多

少？
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hint:你可以加上一個 1V 的 DC votage 在 A、B 點之間，利用 DC op pnt找出

流過節點 A 的電流值，相除即得等效電阻。

R

R

R

R

R
R

R R

R

R

R R

A

B

C

D

Figure 33: 電阻骰子

excercise 8.2：：： 生生生成成成方方方波波波

請利用 PULSE 功能製造出一個週期為 2 �s，振幅為 2.5 V 無 DC 分量的方波。

將這個電源接上 4.7 kΩ 的電阻負載（串聯並接地），觀察電流波形檢驗參數是否設

置正確。

excercise 8.3：：： 生生生成成成鋸鋸鋸齒齒齒波波波

參考 Fig. 34 ，請利用 PULSE 功能製造出一個週期為 2 �s，振幅為 2.5 V 無

DC 分量的鋸齒波。將這個電源接上 4.7 kΩ 的電阻負載（串聯並接地），觀察電流

波形檢驗參數是否設置正確。
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0 V

2.5 V

-2.5 V

Figure 34: 鋸齒波波形
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